Email Deliverability Issue

Incident Report for Rezdy

Resolved

This incident has been resolved.
Posted Jun 29, 2025 - 05:40 UTC

Update

We're marking the issue with emailing service as resolved. If you notice any issues with your email deliverability, please reach out to our customer care. We apologise for any inconvenience caused.
Posted Jun 29, 2025 - 05:40 UTC

Identified

The issue with our email provider has been identified and we're working closely with them to resolve this as soon as possible.
Posted Jun 29, 2025 - 03:34 UTC

Investigating

We are investigating an issue with our email provider, preventing all emails from Rezdy to be sent.
We apologise for the inconvenience caused. We are working closely with our email provider to resolve the issue ASAP.
Posted Jun 29, 2025 - 00:52 UTC
This incident affected: Rezdy emailing.