SMS Deliverability in the United States and Canada

Incident Report for Rezdy

Resolved

The issue with our 3rd party provider has been resolved. We apologise for any inconvenience caused.
Posted Mar 30, 2025 - 22:12 UTC

Identified

We're aware of an issue affecting deliverability of SMS in the United States and Canada. Our team is actively working on resolution with our 3rd party provider. We apologise for any inconvenience caused.
Posted Mar 27, 2025 - 05:28 UTC
This incident affected: Rezdy mobile numbers (SMS number).