Rezdy suppliers cannot add new agents
Incident Report for Rezdy
Resolved
This incident has been resolved.
Posted Aug 17, 2022 - 04:31 UTC
Update
We are continuing to work on a fix for this issue.
Posted Aug 17, 2022 - 04:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 17, 2022 - 03:45 UTC