Rezdy.com is down due to a 3rd party world-wide outage
Incident Report for Rezdy
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 07:21 UTC
Monitoring
A major 3rd party outage that is affecting businesses globally, including our marketing website http://rezdy.com. You can still log in to the Rezdy application directly at 'https://auth.rezdy.com/login'.
Posted Jun 21, 2022 - 07:03 UTC
This incident affected: Rezdy Website [rezdy.com].